Вы здесь: ГлавнаяПрактика МСФОЭксель для финансистаЗаполнение пустой ячейки значением предыдущей ячейки в эксель (excel)

Заполнение пустой ячейки значением предыдущей ячейки в эксель (excel)

Иногда в практике возникает необходимость заполнить ячейку значением предыдущей ячейки.
Например, сделать такое преобразование:

Zapolnenie yachhek1

Для этого существуют макросы, но решить задачу можно простыми функциями эксель.
Создаем рядом столбец и пользуемся функцией «ЕСЛИ»:
Если в исходной ячейке пустота, то ячейка заполняется значением предыдущей ячейки.
Если в исходной ячейке не пусто, то ячейка заполняется исходным значением.
Так в ячейке A4 находится следующая формула: A4=ЕСЛИ(B4="";A3;B4).
Остается только протянуть формулу до конца списка.

Zapolnenie yachhek2

Пример из статьи можно скачать